Вставить галочку в Excel

Сегодня мы научимся создавать в MS Excel «чеклист» или, если по-русски, список дел. Список дел в Excel — с этим вы наверняка уже сталкивались в попытках организовать работу. Обычно люди выделяют цветом сделанные/несделанные дела, «зачеркивают» пункты списка... но все это слишком долго, да и просто неудобно.

Гораздо проще все это можно реализовать с помощью «галочек» — установки и снятия т.н. «флажков». Ну, а чтобы все не было так просто, мы сделаем наш список дел более функциональным: снабдим внутренним счетчиком и счетчиком выполнения задач.

Расставляем флажки в MS Excel

Сначала создадим простейшую таблицу со списком дел. Затем перейдем на вкладку «Разработчик» и в группе «Элементы управления» активируем инструмент «Вставка» и выберем пункт «Флажок». Как только флажок окажется помещенным на листе, сотрите ненужную подпись и поставьте его в выбранную ячейку.

Использование "флажков" в Excel

Теперь протяните ячейку с флажком за уголок до конца «списка дел», и такие же «флажки» появятся во всех остальных ячейках столбца. Итак шаблончик будущего списка дел готов — можно даже щелкать по флажкам уже сейчас, расставляя галочки... только вот удовольствия и пользы от этого никакого, верно? Давайте её добавим!

Протягиваем ячейку MS Excel, чтобы заполнить все другие ячейки столбца тем же содержимым
Заготовка списка дел в MS Excel

Список дел с зависимостями в MS Excel

Щелкаем правой кнопкой мыши по первому элементу-флажку, и выбираем самый нижний пункт из выпадающего меню: «Формат объекта».

Список дел с в экселе

В появившемся окне «Форматирование объекта» щелкните в поле «Связь с ячейкой», а затем, щелкните на соседнюю ячейку справа от текущей. Тот же фокус нужно проделать для всех остальных флажков, создав пары с соседней ячейкой.

Создаем связь с ячейкой в MS Excel

Обратите внимание: если поставить галочку на одном из флажков, в «связанной» ячейке появится надпись: «истина» если «галочка» установлена или «ложь», если снята. Пока запомним это просто как интересный факт, и двинемся дальше.

связанные ячейки таблицы эксель

Функция СЧЕТЕСЛИ

Ну а теперь немого функций и математики. В «список дел» я добавляю ещё 2 строки: число задач вообще, и число задач, которые уже выполнены. Обе строи заполняются данными автоматически, а помогает им в этом встроенная Excel-функция СЧЕТЕСЛИ. Работает она просто:

=СЧЁТЕСЛИ(диапазон_ячеек ; критерий_работы)

Как посчитать все выполненные задачи? Задать в качестве критерия работы функции положение «ИСТИНА» в третьей колонке (как вы помните, положение зависит от того — стоит галочка или нет).

А как посчитать все задачи (и выполненные и невыполненные) сразу? Сначала посчитать по отдельности количество значений «ЛОЖЬ» и «ИСТИНА», а затем сложить результат.

Считаем задачи в нашем excel-списке дел

В общем и целом, наш список дел или список задач на день построенный в MS Excel, уже готов. Нужно только немного украсить его и сделать более опрятным.

Итоговый список задач в MS Excel

Первым делом скройте столбец «С» (истина/ложь), чтобы он не загромождал вид таблицы. А во вторых, давайте добавим «общий критерий эффективности», то есть ещё одно поле — «можно ли переходить к следующему плану?». Ёжику понятно, что переходить к следующему плану можно только после того, как выполнены все задания нынешнего. Или, перефразируя с языка логики на язык математики: когда пункты «всего задач» и «задач выполнено» нашего списка, равны друг другу!

Воспользуемся простой функцией условием =ЕСЛИ() и зададим исходные данные:

=ЕСЛИ(B8=B7 ; «Да» ; «НЕТ»)

Расшифровывается это просто: если значения равны, то вывести в ячейке слово «ДА», если не равны, «НЕТ». А результат будет выглядеть как у меня на примере ниже.

Готовый список задач сделанный в MS Excel.

Обратите внимание только на одну деталь — зеленый цвет ячейки и белый цвет текста в ней. Эти элементы также не мои художества, а результат работы MS Excel, а вернее, принципов условного форматирования, о чем мы говорили с вами в одном из прошлых уроков.