Сложные таблицы в Excel

Сводные таблицы Excel представляют собой невероятно мощную функцию, и вы часто можете создавать их вместо формул. В этой статье описывается простая задача, и для нее предлагаются три различных решения. На рис. 103.1 показан набор данных, который содержит оценки студентов по тесту. Цель состоит в вычислении среднего балла для всех студентов, а также среднего балла для каждого пола.

Рис. 103.1. Нужно найти самый лучший способ вычислить средний балл по тесту для парней и девушек

Вставка промежуточных итогов

Первое решение включает в себя автоматическую вставку промежуточных итогов. Чтобы можно было использовать этот метод, данные должны быть отсортированы по столбцу, который будет вызывать промежуточные итоги. В данном случае вам нужно сортировать данные в столбце Пол. Выполните следующие действия.

  1. Выберите любую ячейку в столбце С.
  2. Щелкните правой кнопкой мыши и в контекстном меню выберите Сортировка ► Сортировка от А до Я.
  3. Выберите Данные ► Структура ► Промежуточный итог для открытия диалогового окна Промежуточные итоги.
  4. В окне Промежуточные итоги выберите в списке При каждом изменении в пункт Пол, в списке Операция — Среднее, а в поле Добавить итоги по установите флажок Оценка.

Результат добавления промежуточных итогов показан на рис. 103.2. Обратите внимание, что Excel также создает контур, так что вы можете скрыть подробности и просматривать только итоги. Формулы, добавленные Excel, используют функцию ПРОМЕЖУТОЧНЫЕ.ИТОГИ со значением 1 в качестве первого аргумента (1 обозначает среднее). Вот эти формулы: =ПРОМЕЖУТОЧНЫЕ.ИТОГИ(1;B2:B13) =ПРОМЕЖУТОЧНЫЕ.ИТ0ГИ(1;B15:B28) =ПРОМЕЖУТОЧНЫЕ.ИТОГИ(1;B2:B28) Формула в ячейке В30 вычисляет общее среднее и использует диапазон, который включают в себя другие две формулы ПРОМЕЖУТОЧНЫЕ.ИТОГИ в ячейках В14 и В29. Функция ПРОМЕЖУТОЧНЫЕ.ИТОГИ игнорирует ячейки, которые содержат другие формулы ПРОМЕЖУТОЧНЫЕ.ИТОГИ.

Рис. 103.2. Excel добавляет промежуточные итоги автоматически

Использование формул

Другой способ вычисления средних значений заключается в использовании формул. Формула для расчета среднего для всех студентов простая: =СРЗНАЧ(B2:B27).

Чтобы узнать среднее значение в зависимости от пола, можете воспользоваться функцией СРЗНАЧЕСЛИ для создания следующих формул: =СРЗНАЧЕСЛИ(C2:C27;"Женский";B2:B27) =СРЗНАЧЕСЛИ(C2:C27;"Мужской";B2:B27)

Функция СРЗНАЧЕСЛИ была введена в Excel 2007. Если вам нужно, чтобы ваша книга была совместима с более ранними версиями, используйте эти формулы: =СУММЕСЛИ(C2:C27;"Женский";B2:B27)/СЧЕТЕСЛИ(C2:C27;"Женский") =СУММЕСЛИ(C2:C27;"Мужской";B2:B27)/СЧЕТЕСЛИ(C2:C27;"Мужской")

Использование сводной таблицы

Третий метод усреднения баллов состоит в создании сводной таблицы. Многие пользователи избегают создания сводных таблиц, поскольку считают эту функци.ю слишком сложной. Однако, как вы сможете видеть, она проста в использовании.

  1. Выберите любую ячейку из диапазона данных и выполните команду Вставка ► Таблицы ► Сводная таблица для открытия диалогового окна Создание сводной таблицы.
  2. В диалоговом окне убедитесь, что Excel выбрал правильный диапазон данных, и укажите ячейку в текущем листе в качестве местоположения. Ячейка Е1 будет неплохим выбором.
  3. Нажмите кнопку ОК, и Excel отобразит список полей сводной таблицы.
  4. В списке полей перетащите пункт Пол в раздел Названия строк, в самый низ.
  5. Перетащите пункт Оценка в раздел Значения. Excel создаст сводную таблицу, но отобразит функцию СУММ, а не СРЗНАЧ.
  6. Чтобы изменить используемую итоговую функцию, щелкните правой кнопкой мыши на любом значении в сводной таблице и выберите Итоги по ► Среднее в контекстном меню (рис. 103.3).
Рис. 103.3. Эта сводная таблица вычисляет средние значения без использования формул

В отличие от решения на базе формул, сводная таблица не обновляется автоматически при изменениях данных. Если данные изменились, вам нужно обновить сводную таблицу. Просто щелкните правой кнопкой мыши на любой ячейке сводной таблицы и выберите в контекстном меню пункт Обновить.

Сводная таблица в этом примере очень проста, и се было также очень легко создавать. Сводные таблицы могут быть намного более сложными, обобщая большие объемы данных практически любым образом, о котором вы только могли бы подумать, и без использования формул.