Задать условия в ячейках Excel

Excel — отличный числовой редактор, на основе которого удаётся создавать уникальные сводные отчёты, сопровождаемые важными математическими, логическими, аналитическими действиями.

Логические формулы в Еxcel

Основные операции

Освоив простейшие азы, можно приступать к созданию логических формул.

Для начала работы следует запустить само офисное приложение. Далее важно определиться, что должно посчитаться автоматически. Чаще всего к работе приступают, когда уже имеется числовая информация, на основе которой приходится осуществлять множественные операции при помощи калькулятора. Теперь эту счётную машинку нужно отложить в сторону и полностью довериться электронной таблице.

Часто необходимо не просто осуществлять подсчёты, используя данные в таблице, а проводить анализ, сопровождаемый несколькими условиями. Опять-таки всё это проделывать самостоятельно вручную неразумно, когда имеются такие уникальные возможности Excel, способной выполнять любые требования пользователя.

Функция ЕСЛИ состоит из трёх аргументов:

Итак, можно попробовать создать простейшую вычислительную таблицу, взяв за основу пример, где главной будет логическая функция ЕСЛИ.

В частности, в ячейку А1 ввести числовой показатель «5», а в ячейку А2 показатель «8». Если пользователю необходимо сравнить два показателя и выдать автоматический итог произведённых действий, составляется выражение, которое, безусловно, начинается со знака «равно»: =ЕСЛИ(А1>А2; «Больше»; «Меньше»). После введения этой записи в любую свободную ячейку, нажатия Enter, в ней сразу будет демонстрироваться ответ. Если пользователь заменит значения в А1 или А2, то ответ также автоматически перестроится.

Составление функций с несколькими условиями

Условное форматирование ячеек

Результат выполнения, состоящих из нескольких критериев, может отображаться в числовом виде, текстовом, а также «подсвечиваться» заданными цветовыми оттенками, что позволяет мгновенно выявить значения, которые так важны тому, кто анализирует данные.

Закрасить определённую область таблицы будет несложно, если пользователь полностью понял принцип, как задать выражение, рассматривающее одновременно два требования.

Если бы нужно было просто задать такую формулу с несколькими требованиями, то она выглядела бы так: =ЕСЛИ(И(СУММ(A1:A2)=5;А3=8);ИСТИНА;ЛОЖЬ). Вводя такую формулу в А4, нажав Enter, мгновенно отобразится либо «истина», если условие выполняется, либо «ложь».

Итак, научиться создавать логические формулы, сопровождаемые несколькими условиями, можно, если проявить усидчивость, скопировать готовые примеры, рассмотреть их на новом листе электронной таблице, после чего составить несколько подобных. Освоив логические формулы, электронная таблица Excel понравится ещё больше, поскольку она будет облегчать выполнение многих задач.