Формула наименьшего значения в Excel

VPR s intervalom 1 Функция ВПР с интервальным просмотром данных Excel

Добрый день уважаемый пользователь Excel!

Продолжая серию статей о возможностях работы с функцией ВПР в Excel, рассмотрим в этой статье, как работает ВПР с интервальным просмотром данных. Очень удобно эту возможность использовать, когда существует несколько условий для формирования расчётов. Часто такая необходимость встречается в работе экономистов, нормировщиков всех направлений, специалистов отдела кадров, работникам торгового отдела.

Чтобы было более понятно, как ее использовать рассмотрим всё на примере. Возьмем работу торгового дома, который продает некий вид товара, а за оптовые закупки делает скидки, которые зависят от суммы закупок товара. Так для чека в размере 10тыс.руб. будет скидка 1%, для чека 20тыс.руб — 3%, для 50тыс.руб — 8%, для 100тыс.руб. — 15%. А вот теперь необходимо найти процент скидки в зависимости от суммы чека.

Эту работу можно произвести с помощью функции ЕСЛИ, и как это сделать я уже описывал, перейдя по ссылке, можете ознакомиться с таким способом, а в нашем случае получится формула:

=ЕСЛИ (B2<$F$3 ; «„; ЕСЛИ (B2<$F$4; $G$3; ЕСЛИ (B2<$F$5; $G$4; ЕСЛИ (B2<$F$6; $G$5; $G$6)))).

Как видите, формула немножко великовата и запутана для неискушённого пользователя Microsoft Excel. Тем более что функционал функции ЕСЛИ ограничен только 7 вложениями разных условий (ну хотя в последних релизах Excel уже разрешено 64 вложенных условия), а вот вдруг условий нужно больше? А представьте, как будет выглядеть такая формула…

Но в нашем случае есть выход, простой, элегантный и красивый. Создадим таблицу с примерами по объемам продаж и отдельно выведем нашу таблицу скидок:

VPR s intervalom 2 Функция ВПР с интервальным просмотром данных Excel

Теперь для расчёта скидок можно использовать формулу:

=ВПР(B2;$F$3:$G$6;2;ИСТИНА), где:

  • Аргумент („B2“) — производит проверку значения содержащегося в ячейку на соответствия заданным условиям;
  • Аргумент („$F$3:$G$6“) — указывает на диапазон таблицы, в которой производится поиск;
  • Аргумент („2“) — вводится номер столбика из поисковой таблицы, в котором будет производиться изъятие значения скидки;
  • Аргумент („ИСТИНА“) — указывается для не точного поиска совпадений, а именно будет произведен поиск ближайшего наименьшего значения и получения процента скидки для него. В принципе это самый главный аргумент для качественной работы формулы. Что и было необходимо!

VPR s intervalom 3 Функция ВПР с интервальным просмотром данных Excel

В случае если вы ходите автоматизировать свою таблицу и улучшить ее визуализацию можно устранить получаемые ошибки вывода данных с помощью функции ЕСЛИОШИБКА и тогда формула приобретёт такой вид:

=ЕСЛИОШИБКА(ВПР(B2;$F$3:$G$6;2;ИСТИНА);“»).

Рекомендую почитать статью: Используем функцию ВПР в Excel для поиска и отбора значений!

Оцените статью
Как в офисе.ru
Добавить комментарий